System requirements

To use Digimizer, you need a PC with

 

Compatible with Windows 7 Compatible with Windows 8

 

 

Privacy Contact Site map